Fehlendes SSL-Zertifikat

Habt ihr Fehler gefunden oder einfach einen Verbesserungsvorschlag? Immer her damit!
martzl
StreetPass Neuling
StreetPass Neuling
Beiträge: 1
Registriert: Do 29. Aug 2013, 15:06
Wohnort: MH

Fehlendes SSL-Zertifikat

Ungelesener Beitragvon martzl » Do 29. Aug 2013, 15:42

Hallo allerseits!

Entschuldigt bitte, dass ich die Uservorstellung uebersprungen habe und direkt in die Kritik uebergehe ;)
Erstmal: Tolle Idee, mit dem Forum. Wird sicherlich fuer regeren Austausch zwischen den regelmaessigen und unregemaessigeren Streetpass-Besuchern sorgen.
Zu meinem eigentlichen Kritikpunkt.
Ich wurde gerade via der Facebook-Seite der Essener Streetpass-Community hergeleitet und zwar mittels der URL "https://streetpass-germany.de/2013/neu- ... any-forum/".
Leider fiel mir da bereits auf, dass offenbar nur ein selbsterstelltes, aber nicht signiertes, SSL-Zertifikat hat.
Das soll ja erstmal generell kein Problem darstellen, da ich auf der streetpass-germany-Seite ja erstmal keine sicherheitsrelevanten Dinge (z.B. Name, Emailadresse, Passwort o.Ae.) angeben muss.
Was sich fuer mich als problematischer darstellt ist das gaenzlich fehlende Zertifikat fuer den VHost/die Subdomain forum.streetpass-germany.de.
Hier findet offensichtlich sogar direkt ein Redirect auf die default page "It works!" des Plesk/Apache statt.
Beim Forum sehe ich den Mangel eines Zertifikates als problematisch an. Hier uebermittle ich persoenliche Daten, wie Name, Emailadresse, Geburtsdarum und nicht zuletzt auch ein Passwort (welches beim ein oder anderen Benutzer vielleicht noch nicht einmal von jenem abweicht, welches er fuer die Emailadresse benutzt, mit der er sich hier registriert hat). Da wuesste ich schon gern "wem ich da gerade mein Passwort sage".

Ein SSL-Zertifikat fuer eine Domain mit beliebig vielen VHosts ist nicht teuer und, nicht nur meines Erachtens nach, ein unerlaesslicher Grundstein einer Seite/eines Forums, auf der/in dem sich ein Anmeldeformular befindet, bei dem personenbezogene Daten und ein Passwort abgefragt werden.
Empfehlenswert, fuer den Fall, dass kein Geld fuer ein solches Zertifikat vorhanden sein sollte, ist ansonsten ein kostenloses Zertifikat speziell fuer den VHost/die Subdomain forum.streetpass-germany.de
Das kann man zum Beispiel bei StartSSL beantragen, kostet nichts und wird von praktisch allen gaengigen Browsern bereits anerkannt.

Ich hoffe, ich habe mich jetzt nicht direkt unbeliebt gemacht, da ich den Adminstrator/die Administratorin/die Administratoren nur mal freundlich darauf hinweisen und eventuell einen Denkanstoss in die richtige Richtung geben wollte ;)

Bei Anmerkungen/Fragen o.Ae. stehe ich natuerlich gern weiterhin zur Verfuegung.

Benutzeravatar
Tim R.
StreetPass Lübeck
StreetPass Lübeck
Beiträge: 397
Registriert: Di 30. Apr 2013, 21:54
Name: Tim R.
Wohnort: Bad Oldesloe
Kontaktdaten:

Re: Fehlendes SSL-Zertifikat

Ungelesener Beitragvon Tim R. » Do 29. Aug 2013, 16:42

Hallo martzl,

der Blog (StreetPass-Germany.de) und das Forum (forum.streetpass-germany.de) liegen nicht auf dem selben Server, daher fehlt wohl auch noch das Zertifikat. Aber ich werde mir das ganze mal zusammen mit den Server Admins anschauen und mich darum kümmern. Stimme dir natürlich zu, dass es nicht fehlen sollte :)

Danke für den Hinweis.
Bild

Benutzeravatar
Freigeist
StreetPass Bremen
StreetPass Bremen
Beiträge: 114
Registriert: Mo 1. Jul 2013, 12:50
Name: Florian T.
Wohnort: Achim (bei Bremen)

Re: Fehlendes SSL-Zertifikat

Ungelesener Beitragvon Freigeist » Do 29. Aug 2013, 23:04

Zwar hab ich erstmal ein selbstsigniertes Zertifikat erstellt, allerdings meint meint mein Apache das es doch toll wäre dennoch das Zertifikat einer meiner Webseiten zu verwenden, naja kümmer ich mich später drum, jetzt ist SSL erstmal überhaupt verfügbar
Ich mache den selben Fehler nicht nur 2 oder 3 mal, ich mache ihn 5 oder 6 mal um sicher zu gehen.


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast